Blank

Umbraco Status page


Welcome to the Umbraco status page. On this page, you can see the current operational status as well as plans for scheduled maintenance and automatic upgrades for all our cloud offerings: Umbraco Cloud and Heartcore.

Subscribe to updates above to get the latest status send straight to your inbox.

If you’re experience issues with your cloud project which does not seem to relate to the current operational status, please go to Our Umbraco and search for the issue or reach out to the Umbraco Support in the portal chat.

Umbraco .com is currently unavailable
Incident Report for Umbraco Cloud
Resolved
Issue has been fixed and umbraco.com is working again.
Posted Apr 29, 2021 - 11:57 CEST
Update
We are continuing to investigate this issue.
Posted Apr 29, 2021 - 11:45 CEST
Investigating
Umbraco.com is currently unavailable. We are investigating the issue. Nothing indicates that this is related to Umbraco Cloud.
Posted Apr 29, 2021 - 11:44 CEST
This incident affected: umbraco.com.