Resolved
All issues with slow performance are now resolved.
Monitoring
We have identified the underlying issue and successfully rolled out a fix. System performance is improving, and we are actively monitoring to confirm full recovery.
Investigating
Customers experience significantly slow performance across Umbraco Cloud, affecting usability and productivity.