Resolved
The issue has been resolved
Monitoring
We've identified the issue and performed a fix.
We'll be monitoring the situation throughout the evening / night.
Investigating
Provisioning new environments on Umbraco Cloud experiencing degraded performance.
We are investigating the issue