Blank

Umbraco Status page


Welcome to the Umbraco status page. On this page, you can see the current operational status as well as plans for scheduled maintenance and automatic upgrades for all our cloud offerings: Umbraco Cloud and Heartcore.

Subscribe to updates above to get the latest status send straight to your inbox.

If you’re experience issues with your cloud project which does not seem to relate to the current operational status, please go to Our Umbraco and search for the issue or reach out to the Umbraco Support in the portal chat.

Cloud Portal degraded performance for UK-Region
Incident Report for Umbraco Cloud
Resolved
The root cause has been identified and a fix has been deployed and confirmed working.
The root cause was due to an expired certificate for internal services used in the Umbraco Cloud Portal.
Posted Jan 17, 2024 - 11:29 CET
Investigating
We are aware of degraded performance for the Cloud Portal in the UK-region.
We are investigating to find the root cause and will update you in an hour (12:00 CET)
Posted Jan 17, 2024 - 10:59 CET
This incident affected: Umbraco.io Portal (Umbraco Cloud).