Blank

Umbraco Status page


Welcome to the Umbraco status page. On this page, you can see the current operational status as well as plans for scheduled maintenance and automatic upgrades for our cloud offerings (Umbraco Cloud and Umbraco Heartcore) as well as related services and websites.

Subscribe to updates above to get the latest status send straight to your inbox.

If you’re experience issues with your cloud project which does not seem to relate to the current operational status, please go to Our Umbraco and search for the issue or reach out to the Umbraco Support in the portal chat.

Newly created Umbraco Cloud environments fail with “No sufficient permissions to see file versions”

Incident Report for Umbraco Statuspage

Resolved

This incident has been resolved.
Posted Oct 17, 2025 - 12:25 CEST

Monitoring

The fix has been tested and deployed.
We will continue to monitor the situation
There are instances, where manual intervention is needed, which is consolidated throughout the rest of the day and tomorrow.
Posted Oct 16, 2025 - 17:59 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 16, 2025 - 14:43 CEST

Investigating

We’re investigating an issue where newly created Umbraco Cloud environments show an error when trying to fetch CMS and plugin versions.

Impact:
Customers creating new environments are unable to see file version information and encounter the following message:

"No sufficient permissions to see file versions.
Could not load commits, there might be a deployment in progress. Please try again, or contact support."
Posted Oct 16, 2025 - 09:11 CEST
This incident affected: Umbraco.io Portal (Umbraco Cloud), Umbraco Heartcore (Umbraco Heartcore Services), Umbraco Cloud - UK South (Umbraco Services), Umbraco Cloud - Australia East (Umbraco Services), Umbraco Cloud - Canada Central (Umbraco Services), Umbraco Cloud - Europe West (Umbraco Services), and Umbraco Cloud - US East (Umbraco Services).