Blank

Umbraco Status page


Welcome to the Umbraco status page. On this page, you can see the current operational status as well as plans for scheduled maintenance and automatic upgrades for all our cloud offerings: Umbraco Cloud and Heartcore.

Subscribe to updates above to get the latest status send straight to your inbox.

If you’re experience issues with your cloud project which does not seem to relate to the current operational status, please go to Our Umbraco and search for the issue or reach out to the Umbraco Support in the portal chat.

Azure Virtual Machines Outages
Incident Report for Umbraco Cloud
Resolved
Umbraco Cloud hosting has not been affected by the CrowdStrike Falcon agent incident.
Posted Jul 22, 2024 - 12:32 CEST
Monitoring
Our team continues to monitor the situation.
Posted Jul 22, 2024 - 11:50 CEST
Investigating
We are aware that some Azure Virtual Machines have been impacted by a BSOD issue, as reported by Azure status page (https://azure.status.microsoft/en-us/status). Umbraco Cloud hosting is not affected - our team will continue to monitor the situation.
Posted Jul 19, 2024 - 11:03 CEST