Blank

Umbraco Status page


Welcome to the Umbraco status page. On this page, you can see the current operational status as well as plans for scheduled maintenance and automatic upgrades for all our cloud offerings: Umbraco Cloud and Heartcore.

Subscribe to updates above to get the latest status send straight to your inbox.

If you’re experience issues with your cloud project which does not seem to relate to the current operational status, please go to Our Umbraco and search for the issue or reach out to the Umbraco Support in the portal chat.

Downtime
Incident Report for Umbraco Cloud
Resolved
We have identified the issue as a false-positive from our monitoring service, therefore normal operations have not been affected.
Posted Jun 15, 2019 - 14:44 CEST
Monitoring
Some customers might have experienced downtime from 13:25 -13:40 (CEST).
We are currently investigating the issue.
Posted Jun 15, 2019 - 14:20 CEST