Blank

Umbraco Status page


Welcome to the Umbraco status page. On this page, you can see the current operational status as well as plans for scheduled maintenance and automatic upgrades for all our cloud offerings: Umbraco Cloud and Heartcore.

Subscribe to updates above to get the latest status send straight to your inbox.

If you’re experience issues with your cloud project which does not seem to relate to the current operational status, please go to Our Umbraco and search for the issue or reach out to the Umbraco Support in the portal chat.

UmbracoID 2FA email delivery delayed
Incident Report for Umbraco Cloud
Resolved
This incident has been resolved.
Posted Feb 05, 2024 - 09:06 CET
Monitoring
A fix has been implemented and the authentication emails are being delivered again; we are monitoring the affected components.
Posted Feb 04, 2024 - 17:31 CET
Identified
We have identified the root cause of the problem and we are in contact with the relevant service providers.
It appears that the Outlook email provider in particular is affected by this problem.
For urgent requests, please note you can reset the Multi-Factor Authentication by reaching out to Umbraco Support.
Posted Feb 02, 2024 - 15:25 CET
Investigating
Two-factor authentication emails for UmbracoID may take more than usual to arrive. We are currently investigating this issue. If you are affected by the issue, please note you can reset the Multi-Factor Authentication by reaching out to Umbraco Support.
Posted Feb 02, 2024 - 11:46 CET
This incident affected: Umbraco Id.