Blank

Umbraco Status page


Welcome to the Umbraco status page. On this page, you can see the current operational status as well as plans for scheduled maintenance and automatic upgrades for all our cloud offerings: Umbraco Cloud and Heartcore.

Subscribe to updates above to get the latest status send straight to your inbox.

If you’re experience issues with your cloud project which does not seem to relate to the current operational status, please go to Our Umbraco and search for the issue or reach out to the Umbraco Support in the portal chat.

Performance degradation on Umbraco Cloud sites
Incident Report for Umbraco Cloud
Postmortem

During the period of Friday 2nd of April at 12:13 - 13:13 CEST, A Microsoft Azure incident negatively impacted Umbraco Cloud resulting in some customers experiencing hosting downtime and/or general instability. This post mortem will outline the events as they occurred, give details on the root cause and explain what steps we are taking to improve and prevent similar incidents based on these learnings.

Summary and root cause

At 12:13 CEST an Azure’s Network Infrastructure incident started to negatively impact Umbraco Cloud. This issue caused some websites on Umbraco Cloud to experience timeout issues. 

On April 2nd, 2021 at 12:20 CEST, networking monitoring alerted us that there was an unusual drop in traffic allowing us to quickly pinpoint where the issue lies.
A workaround was found at around 12:25 CEST and applied at 12:35 CEST.
At 12:43 CEST, all services started to serve content as expected.

Recovery timeline

Site recovery timeline:

  • 70% of sites recovered before 12:49 CEST
  • 80% of sites recovered before 13:07 CET
  • 100% of sites recovered before 13:13 CET

Follow Up

Microsoft has confirmed that the incident was caused by issues with the Microsoft Azure services.

We have hardened our alerting further to have a better reaction time in the future thus decreasing downtime for any affected sites. 

We apologize for the inconveniences this incident has caused you and your customers. Ensuring our stable operations on Umbraco Cloud is our highest priority, and we will continue our efforts to ensure continued stability for both our current and future platforms.

Additionally, we are currently in the process of migrating Umbraco Cloud to a new infrastructure, you can read details about this journey here.

Posted Apr 09, 2021 - 12:52 CEST

Resolved
This incident has been resolved.
We will release a post-mortem about this incident here on the Umbraco Cloud Status Page no later than on Tuesday 6th of April at 17:00 CEST

Update: Due to an ongoing support ticket with Microsoft we have postponed the release of the post-mortem. We will release it here on Umbraco Cloud Status Page no later than Friday 9th of April at 16:00 CEST.
Posted Apr 02, 2021 - 14:55 CEST
Update
We are continuing to monitor the situation, all sites are available since 13:15 CEST
Posted Apr 02, 2021 - 14:09 CEST
Monitoring
The issue seems to have been related to an incident on Azure DNS.
We have applied a workoround and we will continue monitoring the situation.
Posted Apr 02, 2021 - 13:23 CEST
Investigating
We are currently investigating this issue.
Posted Apr 02, 2021 - 12:34 CEST
This incident affected: Umbraco Cloud - Europe West (Website Hosting) and Umbraco Heartcore (Umbraco Heartcore - API, Umbraco Heartcore - Backoffice, Umbraco Heartcore Services).