Blank

Umbraco Status page


Welcome to the Umbraco status page. On this page, you can see the current operational status as well as plans for scheduled maintenance and automatic upgrades for our cloud offerings (Umbraco Cloud and Umbraco Heartcore) as well as related services and websites.

Subscribe to updates above to get the latest status send straight to your inbox.

If you’re experience issues with your cloud project which does not seem to relate to the current operational status, please go to Our Umbraco and search for the issue or reach out to the Umbraco Support in the portal chat.

Umbraco Cloud Portal - Unable to add new environments
Incident Report for Umbraco Statuspage
Resolved
This incident has been resolved.
Posted Jan 16, 2025 - 19:04 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 16, 2025 - 17:47 CET
Update
We are continuing to work on a fix for this issue.
Posted Jan 16, 2025 - 17:16 CET
Identified
We have identified an issue where users currently can't add environments to existing projects in the Umbraco Cloud Portal. The first identified issue has been reported at 13:56 UTC.
Posted Jan 16, 2025 - 17:11 CET
This incident affected: Umbraco.io Portal (Umbraco Cloud), Umbraco Cloud - UK South (Umbraco Services), Umbraco Cloud - Australia East (Umbraco Services), Umbraco Cloud - Europe West (Umbraco Services), and Umbraco Cloud - US East (Umbraco Services).